Commit 35ac25b9 authored by Jan Möbius's avatar Jan Möbius

qt 5.13

parent e93e3dda
Pipeline #11139 failed with stages
in 17 minutes and 57 seconds
...@@ -48,9 +48,11 @@ elif [ "$LANGUAGE" == "C++11" ]; then ...@@ -48,9 +48,11 @@ elif [ "$LANGUAGE" == "C++11" ]; then
BUILDPATH="$BUILDPATH-cpp11" BUILDPATH="$BUILDPATH-cpp11"
fi fi
if [ "$QTVERSION" == "QT5.13.0" ]; then
echo "Using QT5.13.0";
if [ "$QTVERSION" == "QT5.12.2" ]; then BUILDPATH="$BUILDPATH-qt5.13.0"
OPTIONS="$OPTIONS -DQWT6_INCLUDE_DIR=~/sw/qwt-6.1.4-qt5.13.0/include -DQWT6_LIBRARY_DIR=~/sw/qwt-6.1.4-qt5.13.0/lib -DQWT6_LIBRARY=~/sw/qwt-6.1.4-qt5.13.0/lib/libqwt.so -DQT5_INSTALL_PATH=~/sw/Qt/5.13.0/gcc_64"
elif [ "$QTVERSION" == "QT5.12.2" ]; then
echo "Using QT5.12.2"; echo "Using QT5.12.2";
BUILDPATH="$BUILDPATH-qt5.12.2" BUILDPATH="$BUILDPATH-qt5.12.2"
OPTIONS="$OPTIONS -DQWT6_INCLUDE_DIR=~/sw/qwt-6.1.4-qt5.12.2/include -DQWT6_LIBRARY_DIR=~/sw/qwt-6.1.4-qt5.12.2/lib -DQWT6_LIBRARY=~/sw/qwt-6.1.4-qt5.12.2/lib/libqwt.so -DQT5_INSTALL_PATH=~/sw/Qt/5.12.2/gcc_64" OPTIONS="$OPTIONS -DQWT6_INCLUDE_DIR=~/sw/qwt-6.1.4-qt5.12.2/include -DQWT6_LIBRARY_DIR=~/sw/qwt-6.1.4-qt5.12.2/lib -DQWT6_LIBRARY=~/sw/qwt-6.1.4-qt5.12.2/lib/libqwt.so -DQT5_INSTALL_PATH=~/sw/Qt/5.12.2/gcc_64"
......
...@@ -21,9 +21,9 @@ set( CMAKE_CXX_STANDARD 11 ) ...@@ -21,9 +21,9 @@ set( CMAKE_CXX_STANDARD 11 )
# ACG Environment default settings # ACG Environment default settings
# This is ugly but currently we need to work around the default installed on debian # This is ugly but currently we need to work around the default installed on debian
if ( EXISTS /ACG/acgdev/gcc-x86_64/qt-5.12.2/5.12.2/gcc_64 ) if ( EXISTS /ACG/acgdev/gcc-x86_64/qt-5.13.0/5.13.0/gcc_64 )
# Default to this install path for QT%_INSTALL_DIR # Default to this install path for QT%_INSTALL_DIR
set (QT5_INSTALL_PATH /ACG/acgdev/gcc-x86_64/qt-5.12.2/5.12.2/gcc_64/ CACHE PATH "Qt5 install path set for ACG environment using QT 5.12.2" ) set (QT5_INSTALL_PATH /ACG/acgdev/gcc-x86_64/qt-5.13.0/5.13.0/gcc_64/ CACHE PATH "Qt5 install path set for ACG environment using QT 5.13.0" )
endif() endif()
if ( WIN32 ) if ( WIN32 )
...@@ -128,7 +128,7 @@ if ( WIN32 ) ...@@ -128,7 +128,7 @@ if ( WIN32 )
endif() endif()
endif() endif()
set (OF_MAX_QT_VERSION "5.12.2") set (OF_MAX_QT_VERSION "5.13.0")
if (${Qt5Core_VERSION_STRING} STRGREATER ${OF_MAX_QT_VERSION}) if (${Qt5Core_VERSION_STRING} STRGREATER ${OF_MAX_QT_VERSION})
message(WARNING "Detected QT Version higher than ${OF_MAX_QT_VERSION}!\n" "OpenFlipper has not been tested with this QT Version.") message(WARNING "Detected QT Version higher than ${OF_MAX_QT_VERSION}!\n" "OpenFlipper has not been tested with this QT Version.")
......
Subproject commit 31a7484cd896f46941becc0852aa7c5e4f324bc6 Subproject commit a6232f27fc7c5c442799fc8f8781a380d00021c8
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment