...
 
Commits (2)
......@@ -18,7 +18,8 @@
- Moved Icon into Plugin
- <b>Build System</b>
- Improved Branding support
- Support for Qt up to 5.9
- Support for Qt up to 5.9 (Using an lts version 5.9 or 5.6 is recommended)
- Warn if problematic Qt version is used (5.7 and 5.8 may cause GLErrors on OSX 5.8 overrides moc flags on windows. see https://bugreports.qt.io/browse/QTBUG-58345)
- Support for VS 2017
- Enable C++-11 by default
- Drop support for Qt 4
......
......@@ -79,6 +79,14 @@ if (NOT QT5_FOUND)
message(FATAL_ERROR "Could not found any QT Version. Please specify QT5_INSTALL_PATH (path to bin and include dir) to build with QT5")
endif()
# display warnings if a problematic qt version is used
if ( APPLE )
if ( ${Qt5Core_VERSION_STRING} STREQUAL "5.8.0" OR ${Qt5Core_VERSION_STRING} STREQUAL "5.7.1" )
message(WARNING "You are using a Qt Version that might cause problems on OSX regarding GLErrors. We recommend you to use another version. If you fix any GLErrors on these versions feel free to contribute to OpenFlipper.")
endif()
endif()
if ( WIN32 )
OPTION(USE_UNSUPPORTED_QT "Build OpenFlipper with an unsupported version of Qt e.g. if you fixed the moc issue on 5.8.0 yourself" OFF)
if ( ${Qt5Core_VERSION_STRING} STREQUAL "5.8.0" )
......